Camouflage Encoder

gives your software the best protection and prevents any manipulation and transfer of knowledge.



 

The Encoder

You have put years of work into the development of your software products? Therefore it is absolutely important that this work, and your know-how, remains with your customers and your benefit.

Since you make your products, trial versions and demos available as part of a digital download, it is more important that you give your software the best possible protection.

The Camouflage encoder encrypts your PHP source code so that it can't be read or changed. It converts plain PHP source files to encrypted byte code, which can then be executed by a loader extension.

This gives your software the best protection and prevents any manipulation and transfer of knowledge.

buy now

The Decoder

At runtime, the free Camouflage Decoder performs your encrypted application on the server like ordinary PHP scripts without compromising performance.

For your customers, this avoids any additional costs. No registration required.

download now


Features

 guaranteed support for new PHP versions within 3 months
 rapid and timely adaptation to future versions (other manufacturers often require months for adjustments)
 Linux, Mac OS X and Windows support
 full support for PHP 5.3 and PHP 5.4
 support for Xdebug and APC extensions
 developed by a member of the PHP core development team
 Based on open source technologies

Requirements

Operating systems:

  • Linux x86 and x86-64
  • Windows x86
  • Mac OS X x86-64 (intel)

To run Camouflage Encoder/Decoder a PHP 5.3 or PHP 5.4 environment is required. To encode files with Camouflage Encoder PHP must be configured with the pcre and the tokenizer extension and must be available as command line interface.

Stay informed

Follow us on twitter @phpencode to stay up-to-date.